[Clfs-support] tcl8.4.16 build error with SVN-20080213

Joe Ciccone jciccone at gmail.com
Tue Feb 19 18:30:19 PST 2008

Shawn Jin wrote:
> Hi,
> I'm building the CLFS for a x86_64 target on a native x86_64 system
> with Fedora 6 installed.
> I'm have a build error on tcl8.4.16. The error messages are as
> follows. BTW, I'm using the chroot path.
> gcc -shared -O2  -pipe  -DTCL_DBGX=   -Wl,--export-dynamic -o
> libtcl8.4.so regcomp.o regexec.o regfree.o regerror.o tclAlloc.o
> tclAsync.o tclBasic.o tclBinary.o tclCkalloc.o tclClock.o tclCmdAH.o
> tclCmdIL.o tclCmdMZ.o tclCompCmds.o tclCompExpr.o tclCompile.o
> tclDate.o tclEncoding.o tclEnv.o tclEvent.o tclExecute.o tclFCmd.o
> tclFileName.o tclGet.o tclHash.o tclHistory.o tclIndexObj.o
> tclInterp.o tclIO.o tclIOCmd.o tclIOGT.o tclIOSock.o tclIOUtil.o
> tclLink.o tclListObj.o tclLiteral.o tclLoad.o tclMain.o tclNamesp.o
> tclNotify.o tclObj.o tclPanic.o tclParse.o tclParseExpr.o tclPipe.o
> tclPkg.o tclPosixStr.o tclPreserve.o tclProc.o tclRegexp.o
> tclResolve.o tclResult.o tclScan.o tclStringObj.o tclThread.o
> tclThreadAlloc.o tclThreadJoin.o tclStubInit.o tclStubLib.o tclTimer.o
> tclUtf.o tclUtil.o tclVar.o tclUnixChan.o tclUnixEvent.o tclUnixFCmd.o
> tclUnixFile.o tclUnixPipe.o tclUnixSock.o tclUnixTime.o tclUnixInit.o
> tclUnixThrd.o tclUnixCompat.o tclUnixNotfy.o memcmp.o strstr.o
> strtoul.o strtod.o fixstrtod.o tclLoadDl.o   -ldl  -lieee -lm
> -Wl,-rpath,/tools/lib
> fixstrtod.o: In function `fixstrtod':
> fixstrtod.c:(.text+0x0): multiple definition of `fixstrtod'
> strtod.o:strtod.c:(.text+0x0): first defined here
> collect2: ld returned 1 exit status
> make: *** [libtcl8.4.so] Error 1
> My environment is as follows.
> root:~/tcl8.4.16/unix# export
> declare -x BUILD64="-m64"
> declare -x HOME="/root"
> declare -x OLDPWD="/root/tcl8.4.16"
> declare -x PATH="/bin:/usr/bin:/sbin:/usr/sbin:/tools/bin"
> declare -x PS1="\\u:\\w\\\$ "
> declare -x PWD="/root/tcl8.4.16/unix"
> declare -x SHLVL="1"
> declare -x TERM="xterm"
> root:~/tcl8.4.16/unix# mount
> none on /dev/pts type devpts (rw,gid=4,mode=620)
> none on /dev/shm type tmpfs (rw)
> root:~/tcl8.4.16/unix#
> I've tried twice from scatch and both have the same error. Any idea
> why this is happening?
Can you reply to this email with your config.log and config.cache attached?

Also try putting the following in a file named config.cache and add
--cache-file=config.cache to the configure command.


More information about the Clfs-support mailing list