[Clfs-support] trap command

Koornstra, Reinoud koornstra at hp.com
Tue Apr 14 11:58:19 PDT 2009

I tried the x64_64 release, I tried the 1.6 version and 1.5 version.
With the 1.6 version I get this:

Do you agree to the above license terms? [yes or no]
./jre-6u13-linux-x64.bin: line 363: ./install.sfx.24751: No such file or directory
Failed to extract the files.  Please refer to the Troubleshooting section of
the Installation Instructions on the download page for more information.

Same story when I try the 1.5 version, both fail when trying to execute the install.sdx file that is temp created.
When I break the script off, I see indeed that the file is being generated, but for some reason, the script doesn't find it.
Any suggestions?


-----Original Message-----
From: clfs-support-bounces at lists.cross-lfs.org [mailto:clfs-support-bounces at lists.cross-lfs.org] On Behalf Of William Harrington
Sent: Monday, April 13, 2009 11:46 PM
To: CLFS Support
Subject: Re: [Clfs-support] trap command

On Apr 13, 2009, at 1:26 PM, Koornstra, Reinoud wrote:

> Hi,
> I tried to install the sun runtime environment, but it always fails  
> at finding the filename it creates itself.
> Extracting...
> ./jre-6u13-linux-x64.bin: line 363: ./install.sfx.9758: No such file  
> or directory
> Looking at what it does I noticed it assumes several commands are  
> there, like trap.
> I don't have trap install, what package do I need to build to have  
> this command available?
> Any other deps when wishing to do a simple bin install of jre or jdk?
> Kind Regards,
> Reinoud.

I didn't install the x64 release of this, just the i586 release. Trap  
should be with your shell. Do help trap and find out.

jre and jdk should install just fine with a base CLFS build.


Clfs-support mailing list
Clfs-support at lists.cross-lfs.org

More information about the Clfs-support mailing list