[Clfs-support] Error compiling ACPICA (redirected from IASL)

Alonso Graterol alonso.graterol at gmail.com
Mon Apr 7 05:47:31 PDT 2008


   I want to install VirtualBox on a CBLFS AMD Pure64 system and when
fulfilling the IASL requirementet, the compile of ../acpiexec content
throws a bunch of "undefined reference" to AcpiGbl_ functions and
finally exits with error 1.
   I checked my kernel has acpi compiled into. I tried
which is the one referenced in the book and also tried
http://www.acpica.org/download/acpica-unix-20080321.tar.gz and both
gave same error.
  One difference I noted is that 2006 version showed a screen for
configuring several options just right after hitting make. There were
about 10-12 configuration options, all turned on except N° 6 which
deals with some i386 routine call dealing with GCC (sorry, I can't
recall the exact wording). This was the only one turned off and I left
it alone. Version 2008 did not ask anything at all.
  The BCLFS book does not mention any dependency package for
compilation nor any special condition/action to take.
  What could be happening?


More information about the Clfs-support mailing list