[Clfs-support] gmp-4.3.1. fails to compile in Ch. 5, "Constructing Cross Compile Tools"

Dan McGhee beesnees at grm.net
Wed Sep 2 19:08:28 PDT 2009

Dan McGhee wrote:
> Dan McGhee wrote:
>> Using SVN-20090831-Native-Multilib
> <snip>
> After I unsuccessfully tried a few iterations with --build= and 
> --host=, I stumbled on to GMP's ability to search for and *determine 
> *the location of the compiler by passing `--enable-cxx=detect.` My 
> paraphrase of what the manual says is that when you pass 
> `--enable-cxx` `./configure` must know exactly who and where the 
> compiler is. Therefore, if the original guess on the processor is 
> wrong, GMP will not compile. I've seen discussions that ABI=32 may 
> solve the compile problems. (I think ABI is right.) The manual 
> indicates that GPM is really good at choosing 32 or 64 bit libraries 
> depending on which is the most efficient. This, however, is apparently 
> predicated on the success of processor identification and compiler 
> location.
> So I used just the instructions in the book except that I passed 
> `--enable-cxx=determine` and I got past the "find the compiler" point 
> successfully. The compile, however, failed because there is no m4 
> installed in my Ubuntu--boy do I love LFS. I'm going to take care of 
> that and see what happens.
> The other side of this logic is that maybe there is something else 
> going on that I, in my inexperience, can't see. I think what I'm doing 
> now means that m4 is a dependency of GMP, but neither CLFS stable nor 
> development install m4 before GMP. I also don't know if m4 is standard 
> on distributions. Guess I'm gonna learn something else.
Left the write-up in for clarity.

Installed m4 to my Ubuntu 9.04 and changed `--enable-cxx` to 
`--enable-cxx=detect.` Worked like a charm!

Don't know how this affects other people who build GMP, but it might be 
a good idea to suggest the switch as I used it. Also, m4????


More information about the Clfs-support mailing list