[Clfs-support] zlib compiling issue

Koornstra, Reinoud koornstra at hp.com
Mon Apr 6 15:34:23 PDT 2009


Ah, Yes, you are right, I did have it in my env.
I mixed up some pages I guess after the if you're going to boot.
Then the next section was if you're trying to chroot and set variables that I needed there which I don’t need, because I already booted.
I unset all CC etc etc variables and now it works fine.
In my env was set to AR=ar, that overruled the default configure setting.
It compiles well now, thanks,


-----Original Message-----
From: clfs-support-bounces at lists.cross-lfs.org [mailto:clfs-support-bounces at lists.cross-lfs.org] On Behalf Of Joe Ciccone
Sent: Monday, April 06, 2009 3:09 PM
To: CLFS Support
Subject: Re: [Clfs-support] zlib compiling issue

Koornstra, Reinoud wrote:
> Hi,
> I tried to compile zlib following the instruction in 10.11 and I get a
> problem there, apparently ar is given an unknown option:
> ar: illegal option -- z
> This happens after having applied the patch. Without the patch zlib
> compiles fine.
> I don’t see any –z anywhere, any hints?
> Kind Regards,
> Reinoud.
Is the AR variable set in your enviornment?
Clfs-support mailing list
Clfs-support at lists.cross-lfs.org

More information about the Clfs-support mailing list